3
Sacha

Vagrant up fails: synced folders? Timeout? NIC? Guest not trusted? Networking issue?

Hi. Vagrant up ran for a long while, it looked like it downloaded a number of things, but it ended up providing a lot of comment on something that went wrong. 

Many possibilities, most being quite obscure to me: change an environment variable (disable synced folders), change the timeout, change NIC type, ensure guest is trusted, make sure networking is functioning with custom boxes, …

I went to the two URLs provided in the text below but it looked too technical.

Please help.

Here’s the whole text:

P:\Blockgeeks>vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Box 'blockgeeks/env' could not be found. Attempting to find and install...
    default: Box Provider: virtualbox
    default: Box Version: >= 0
==> default: Loading metadata for box 'blockgeeks/env'
    default: URL: https://vagrantcloud.com/blockgeeks/env
==> default: Adding box 'blockgeeks/env' (v0.0.1) for provider: virtualbox
    default: Downloading: https://vagrantcloud.com/blockgeeks/boxes/env/versions/0.0.1/providers/virtualbox.box
==> default: Box download is resuming from prior download progress
    default: Download redirected to host: vagrantcloud-files-production.s3.amazonaws.com
    default:
==> default: Successfully added box 'blockgeeks/env' (v0.0.1) for 'virtualbox'!
==> default: Importing base box 'blockgeeks/env'...
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'blockgeeks/env' is up to date...
==> default: Setting the name of the VM: Blockgeeks_default_1544301680937_80090
Vagrant is currently configured to create VirtualBox synced folders with
the `SharedFoldersEnableSymlinksCreate` option enabled. If the Vagrant
guest is not trusted, you may want to disable this option. For more
information on this option, please refer to the VirtualBox manual:

  https://www.virtualbox.org/manual/ch04.html#sharedfolders

This option can be disabled globally with an environment variable:

  VAGRANT_DISABLE_VBOXSYMLINKCREATE=1

or on a per folder basis within the Vagrantfile:

  config.vm.synced_folder '/host/path', '/guest/path', SharedFoldersEnableSymlinksCreate: false
==> default: Vagrant has detected a configuration issue which exposes a
==> default: vulnerability with the installed version of VirtualBox. The
==> default: current guest is configured to use an E1000 NIC type for a
==> default: network adapter which is vulnerable in this version of VirtualBox.
==> default: Ensure the guest is trusted to use this configuration or update
==> default: the NIC type using one of the methods below:
==> default:
==> default:   https://www.vagrantup.com/docs/virtualbox/configuration.html#default-nic-type
==> default:   https://www.vagrantup.com/docs/virtualbox/networking.html#virtualbox-nic-type
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
==> default: Forwarding ports...
    default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured ("config.vm.boot_timeout" value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you're using a custom box, make sure that networking is properly
working and you're able to connect to the machine. It is a common
problem that networking isn't setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout ("config.vm.boot_timeout") value.

P:\Blockgeeks>

Best answer

Steven Cardon
Yep, ran into the same thing. I started a ticket yesterday; still waiting on an answer. In the meantime I have simply installed ubuntu onto my virtual box so I could get started.

Answers

  1. 3
    Bardia Pourvakil
    Bardia Pourvakil
    Hey guys, sorry about this, we are having a lot of trouble with Windows and Linux users setting up with Vagrant. As the teachers all use Macs, we cannot reproduce the problem. We are working on a new solution for our student’s development environment, which will be released shortly! The best solution I have for you guys in the meantime is to try and locally install all the dependencies needed. Also, we are moving our student questions to Discord, please join here and ask any further questions you have in the appropriate channel: https://discord.gg/phUqFtV
  2. 3
    Sacha
    Thanks Steve and Bardia. Can you tell me a little more about the steps I should take, in more detail?
    Steve, do I need to install Ubuntu and then do the vagrant up thing, that’s all?
    Bardia, how should I install the dependencies? Is that in virtual box?

    Thanks,

    Sacha